Reply

davejh 2 years ago

well 1775 is the port I use and it works flawlessly. I am guessing there will be something not right in your smsglobal.com settings . Have you verified your mobile number on the virtual numbers page? here https://mxt.smsglobal.com/virtual-numbers