SMS settings

asancheznc2 years ago

Hello, regards we have a service with textmagic.com and I would like to configure SMS in Traccar server, can this be done?

<entry key='sms.smpp.enable'>true</entry>
<entry key='sms.smpp.host'>textmagic.com</entry>
<entry key='sms.smpp.port'>2345</entry>
<entry key='sms.smpp.username'>usuario.textmagic</entry>
<entry key='sms.smpp.password'>321321321</entry>
<entry key='sms.smpp.notificationsCharset'>GSM</entry>
<entry key='sms.smpp.notificationsDataCoding'>0</entry>
<entry key='sms.smpp.sourceAddress'>+79000000000</entry>

Thank you

davejh2 years ago

Looks same as my config and its working for me. Although i use smsglobal.com

asancheznc2 years ago

Thanks for answering, I have this message, what will I need?

SMPP session is not connected - SmppChannelException (SmppClient:223 < BaseProtocol:97 < CommandsManager:59 < ...)

Thank

davejh2 years ago

I really have no idea. Maybe you have the username and password wrong preventing your traccar server from connecting to the textmagic server

Anton Tananaev2 years ago

@asancheznc, you need to contact your SMPP provider. Details that you are using are invalid. I tried to connect to the port, but it's not open.

asancheznc2 years ago

Anton Tananaev, Thank you at this time send the request to send me the correct parameters.
Thank you

Sean2 years ago

davejh WOULD you please be kind enough to cut and paste your email settings for SMSGlobal, I have just made an account with them and be nice if you could please help with the setting that you used.

Thank you in Advance

Merry Christmas to all

Sean2 years ago
<entry key='sms.smpp.enable'>true</entry>
<entry key='sms.smpp.host'>smsglobal.com</entry>
<entry key='sms.smpp.port'>2345</entry>
<entry key='sms.smpp.username'>myusername.smsglobal</entry>
<entry key='sms.smpp.password'>mypassword</entry>
<entry key='sms.smpp.notificationsCharset'>GSM</entry>
<entry key='sms.smpp.notificationsDataCoding'>0</entry>
<entry key='sms.smpp.sourceAddress'>+what number should this be?</entry>

as per above thank you

davejh2 years ago

same as Sean above.

Sean2 years ago

davejh can you please CUT PASTE what you have working? as not working for me

Sean2 years ago
<entry key='sms.smpp.enable'>true</entry>
<entry key='sms.smpp.host'>smsglobal.com</entry>
<entry key='sms.smpp.port'>2345</entry>++++++++++++++++++++++++++++++++ IS THIS PORT CORRECT?
<entry key='sms.smpp.username'>myusername.smsglobal</entry>
<entry key='sms.smpp.password'>mypassword</entry>
<entry key='sms.smpp.notificationsCharset'>GSM</entry>
<entry key='sms.smpp.notificationsDataCoding'>0</entry>
<entry key='sms.smpp.sourceAddress'>+what number should this be?</entry>  +++++++++++WHAT NUMBER IN HERE

Anton Tananaev a day ago
@asancheznc, you need to contact your SMPP provider. ???????? WHAT SHOULD THIS BE Anton?

Can anyone please CUT PASTE setting that do work?

Thank you

Anton Tananaev2 years ago

I guess smsglobal is your provider. You should ask them for correct information.

davejh2 years ago
<entry key="sms.smpp.enable">true</entry>
<entry key="sms.smpp.host">smsglobal.com</entry>
<entry key="sms.smpp.port">1775</entry>
<entry key="sms.smpp.username">mysmsglobalusername</entry>
<entry key="sms.smpp.password">mysmsglobalpass</entry>
<entry key="sms.smpp.notificationsCharset">GSM</entry>
<entry key="sms.smpp.notificationsDataCoding">0</entry>
<entry key="sms.smpp.sourceAddress">+441234567890</entry>

Just the same as sean has pasted. Obviously I have changed the sms global username, password and phone number.

Are you trying to enter your smsglobal.com login user and pass into traccar.xml. Because that wont work. Smsglobal issue you with a different user and pass to enter into traccar.xml. When you login go to https://mxt.smsglobal.com/integrations

Anton Tananaev2 years ago

It's clearly not the same. Port is different.

Sean2 years ago

Are you trying to enter your smsglobal.com login user and pass into traccar.xml. Because that wont work

YES I WAS using user name and password, so I will have to get one generated

Will try that now

Thank you