Reoccuring Websocket Connection Error

Ryan Sa year ago

I'm seeing with 4.12 a continous "Websocket Connection Error" when using the Traccar Web app after upgrading to 4.12 from 4.11 where it wasn't present. I thought it was just my instance, but I also saw it on demo.traccar.org when trying to confirm if it was just my setup. It is periodic and I'm not changing network connections as seen if you roam from wifi to cellular and back.

Anton Tananaeva year ago

It was always there and that code hasn't changed for a long time.

Raoula year ago

I see this error as well, every couple of minutes, on my Windows 10 laptop as on my mobile phone (Android).

Anton Tananaeva year ago

The error means that you haven't received any updates in the last 60 seconds.

Ryan Sa year ago

Is there a way to suppress it as it seems more like a debugging message than anything.

Anton Tananaeva year ago

Currently not.

Ronaldoa year ago

Hi Anton,

I just upgraded to v4.12 and am also getting the Websocket connection error message.

If your understanding relates to a problem between the web browser and the server, I realize that this happens when the devices stop communicating (all with the ignition off).

Before in v4.11 I have already spent hours (at night) without the devices transmitting and I did not receive any websocket messages.

Anton Tananaeva year ago

It will be removed with next release.

Kjetil Pedersena year ago

Same issue here with latest release.

Anton Tananaeva year ago

As I said, it will be solved with the next release.

Ariel rodrigueza year ago

Greetings to me, the same thing happens to me when connecting to the websocket from another platform, but you don't let me, it gives me a 503 error, when I try to get a session to add it to the token it doesn't let me, someone could help me

Ariel rodrigueza year ago

When I give it to obtain a session with the token that it generates in tracar's own web version, and I try to generate a session in my own web version, the JSESSIONID cookie does not set me, I have days trying and it does not let me

Hey Anton, I've just upgraded to 4.13 and it is still present, Any updates regarding this?

Anton Tananaeva year ago

If you still this message - you are not using version 4.13. Have you cleared your browser cache?