TK103B Configure help

matzemedia6 years ago

Hello,

I've tried to configure my TK103B without success. I tried to use different ports from the tracker with the same result.


adminip123456 83.37.1.1 5013

Here is a section from the logfile. It lookes like a too short HEX code. I cant figure out the protocol or the identification


2016-03-15 23:05:09  INFO: [8DD03607] connected
2016-03-15 23:05:09 DEBUG: [8DD03607: 5013 < 176.2.127.44] HEX: 78780a1300063d000100035c670d0a
2016-03-15 23:07:26 DEBUG: [8DD03607: 5013 < 176.2.127.44] HEX: 7878251610030f16070dc905bce4fb0119057300340009010603028b0073fb40034302010004b5d20d0a
2016-03-15 23:07:56 DEBUG: [8DD03607: 5013 < 176.2.127.44] HEX: 78780a1350033b0001000564810d0a

Can someone help me?

Regards,
Matze

Anton Tananaev6 years ago

Your device is using GT06 protocol. Correct port is 5023.

matzemedia6 years ago

Thanks for answering. Using port 5023 helps get info in the logfile:

2016-03-17 23:21:42 DEBUG: [7FC914B5: 5023 < 176.0.92.10] HEX: 78780a1340062d0001000ab2e00d0a
2016-03-17 23:21:42 DEBUG: [7FC914B5: 5023 > 176.0.92.10] HEX: 78780513000a57220d0a
2016-03-17 23:21:42  INFO: [7FC914B5] id: 3, time: 1970-01-01 01:00:00, lat: 0.00000, lon: 0.00000, speed: 0.0, course: 0.0

But it is always 0; I mean date, time and geo are 0. I've tried to use the fix:


fix180s***n123456

When sending geo data with sms everything is correct.

Do you have any idea?

Regards

Anton Tananaev6 years ago

It looks like your device doesn't send any location info.