Traccar server on Raspberry Pi 4

Raoula year ago

I have installed the traccar server on an old PC. I installed linux and downloaded traccar and everything works fine.
However considering the power consumption of my old PC I have bought a Raspberry Pi 4 and installed Linux and traccar on it.
Up till inclusive the steps of extracting the traccar file and the creation of the /opt/traccar/... directory everything works fine.

I have a Raspberry Pi 4, 8Gb with a 32 Gb sd card. The linux installed on the RPI is Ubuntu Desktop 20.10 64b
I have tried with the downloads traccar-linux-arm-4.12 and with traccar-linux-64-4.12.

After: "sudo systemctl start traccar" nothing happens. I have tried http://localhost:8082 but no connection is established to the traccar server. I have done the port forwarding steps in the router to the IP address of the Raspberry.

I have the idea that I cannot get the traccar server running one way or the other.
At least when I try the traccar Port Check to port 8082 I get the message that the port is closed.
Do you have any suggestions how to solve this problem?
Is it a port problem or is the traccar server not running?
Kind regards, Raoul

Anton Tananaeva year ago

Have you checked the process? Logs?

Raoula year ago

sorry, I do not know how to do that. I have a very basic knowledge of linux!

Anton Tananaeva year ago

Those are very basic things. If you don't know how to do it, you should probably do some more research and reading about Linux.

Raoula year ago

The Logs file on the RPI (/opt/traccar/logs) is empty!

Raoula year ago

I installed traccar on a Windows PC: no problem.
Later I installed linux on a laptop and put traccar on it: no problem.
Now I have put Linux (Ubuntu 20.10 Desktop 64b) on a Raspberry Pi 4, 8Gb and the Raspberry is working perfectly as a desktop. Thereafter I install traccar for linux (version traccar-linux-64-4.12) on the RPI following the steps as given in the Traccar Documentation.
All the files are correctly installed but after the command "sudo systemctl start traccar" nothing happens. Traccar does not start.
Log files remain empty, the process is not running.
Anybody any suggestions or advice??

Raoula year ago

this is the output of my Linux inquiry:

raoul@Raspberry:~$ ps -ef |grep traccar
raoul      17201   14652  0 13:37 pts/0    00:00:00 grep --color=auto traccar
Raoula year ago

Which file could possibly be missing when traccar server does not start at al in Linux Ubuntu Desktop 20.10? Or missing in the traccar 4.12 files?

Anton Tananaeva year ago
Raoula year ago

see copy:

raoul@Raspberry:~$ java -jar tracker-server.jar conf/traccar.xml
Command 'java' not found, but can be installed with:
sudo apt install default-jre              # version 2:1.11-72, or
sudo apt install openjdk-11-jre-headless  # version 11.0.10+9-0ubuntu1~20.10
sudo apt install openjdk-8-jre-headless   # version 8u282-b08-0ubuntu1~20.10
sudo apt install openjdk-13-jre-headless  # version 13.0.4+8-1
sudo apt install openjdk-14-jre-headless  # version 14.0.2+12-1
sudo apt install openjdk-15-jre-headless  # version 15+36-1
raoul@Raspberry:~$ sudo apt install default-jre
[sudo] password for raoul: 

thereafter I tried the following:

Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
raoul@Raspberry:~$ sudo systemctl start traccar
raoul@Raspberry:~$ java -jar tracker-server.jar conf/traccar.xml
Error: Unable to access jarfile tracker-server.jar
Raoula year ago

in between I see:

Reading state information... Done
default-jre is already the newest version (2:1.11-72).
The following packages were automatically installed and are no longer required:
  cryptsetup-bin dctrl-tools dmeventd dmraid dpkg-repack efibootmgr
  gir1.2-timezonemap-1.0 gir1.2-xkl-1.0 grub-common grub-efi-arm64
  grub-efi-arm64-bin grub-efi-arm64-signed grub2-common kde-window-manager
  kpartx kpartx-boot libdebian-installer4 libdevmapper-event1.02.1
  libdmraid1.0.0.rc16 liblvm2cmd2.03 libqt5designer5 libqt5help5
  libqt5positioning5 libqt5sensors5 libqt5test5 libqt5webchannel5
  libqt5webkit5 libreadline5 libtimezonemap-data libtimezonemap1 lvm2
  os-prober python3-dbus.mainloop.pyqt5 python3-icu python3-pam python3-pyqt5
  python3-pyqt5.qtsvg python3-pyqt5.qtwebkit python3-sip rdate
Use 'sudo apt autoremove' to remove them.
Raoula year ago

so I used the command: sudo apt autoremove'

Anton Tananaeva year ago

Please use some common sense. You have to run the command from the folder where you have Traccar.

Once again, please take your time to do some research before asking for help here. Otherwise you risk not getting help when you actually encounter some real issue. You heard the story of the shepherd boy and the wolf, right?

Raoula year ago

I tried thereafter the following:

raoul@Raspberry:~$ sudo systemctl start traccar
raoul@Raspberry:~$ java -jar tracker-server.jar conf/traccar.xml
Error: Unable to access jarfile tracker-server.jar
AlfSollia year ago

@Raoul: Raspberry is an ARM based, 32Bit computer, so the linux-arm version is what you want. The other one is likely compliled for a x86_64 architecture.

Secondly, from you example, you current path (the working directory you're in) is your users home directory. Is this where the tracker-server.jar file resides?
If you ran the installer, traccar should be in /opt/traccar .
Change directory to this folder with "cd /opt/traccar" and retry the command.

Basic Linux/CLI is definitively recommended, and a bit of study never hurt anyone as far as I know. :)
That said, running this on a Pi will probably limit itself pretty quick. But could be a fun experiment.