Device support for the new Eview Units.

Ketila year ago

Good day, hope everyone is doing fine :)

I have been looking into the forum for support for the newer protocol that eviewgps moved to with the new ev-07b and ev-04 devices. I found 2 posts about the topic but they dont seem to have been solved or the op didnt follow up with a posetive response

I tried with a bunch of the china protocol ports as recommended and other alterntives to see if it brought me any luck, but without a posetive outcome.
So I have gathered the protocol description of the old device series (ev-07S) which is also used for multiple other devices around the same time that model got released. And a description of the new protocol used on the newer devices (ev.04,ev-07b) and upcoming devices.
https://drive.google.com/file/d/12Gwm1vpThhBFze65LiqgJdT4YrXX1WpN/view?usp=sharing

I also find the following two links that might give some insight into the protocol(i hope)
https://gurtam.com/en/gps-hardware/personal/ev-07b#parameters
https://gurtam.com/en/gps-hardware/personal/ev-04#parameters

I was hoping if someone might have the time at one point, to look and see if i have been unlucky with my initial testing and just not found the right port that supports the device, or if it needs to be created.
In case protocol support needs to be implemented, what information could i gather besides potential wireshark dumps and traccar log dump? To make the process as easy as possible for the developer.

All the best
Ketil

Ketila year ago

#I believe I managed to post this in the wrong section, I apologize for that

Anton Tananaeva year ago

Have you tried Minifinder2 protocol?

Ketila year ago

! I didn't even notice that there was a secondary protocol under the device search area.
Anton, do you have a coffee/beer donation link or similar ?

thanks a million

Anton Tananaeva year ago

Yes, you can find donation link here:

https://www.traccar.org/donate/

Ketila year ago

I vote for beer or coffee, but if you choose to go and use it on cake, I will support that choice too :)

Anders Mogensen8 months ago

Hi Ketil
Have you managed to recieve position and speed from the EV-04?

Roy3 months ago

Hi Ketil,
Did you find a solution for EV04 device? is it connecting with you to traccar? Thank you

Anders Mogensen3 months ago

Hi Roy
I forgot to write back with the solution I found. I used the minifinder2 protocol.

Roy3 months ago

Hello Ketil, thank you for your reply.
Did you completely change your traccar version? Or there is a way to add minifinder2 protocol on older traccar version.
Because i have a problem, i have an older traccar version already running, i cannot change all traccar now. You think is there a way to add minifinder2 protocol to our current traccar version? Without updating all our traccar system? Thanks a lot for your help